Problème avec les accents et autres...

Darkam

Padawan
Hello,

J'ai plusieurs applications qui autorisent de créer des répertoires avec des accents et autres caractères de type " ' " par exemple.

Hors visiblement mon Asustor n'aime pas du tout : impossible d'accéder au répertoire ainsi créé. Idem sous XBMC.

Savez-vous comment je pourrais au moins renommer ces répertoires ? Sous SSH directement ?

Merci,

Darkam
 

Dami1

Grand Maître Jedi
Darkam a dit:
Hello,

J'ai plusieurs applications qui autorisent de créer des répertoires avec des accents et autres caractères de type " ' " par exemple.

Hors visiblement mon Asustor n'aime pas du tout : impossible d'accéder au répertoire ainsi créé. Idem sous XBMC.

Savez-vous comment je pourrais au moins renommer ces répertoires ? Sous SSH directement ?

Merci,

Darkam

non directement dans contrôle d'accès/répertoire partagé . sélection du dossier et clic sur "éditer"
si j'ai bien compris la question. perso pas de souci avec les accents. ex : xmbc 12.3 d'ADM 2.1 lit bien le mot "séries" du dossier éponyme. je viens de tester
 

Darkam

Padawan
Cela ne semble pas fonctionner.

Dans contrôle d'accès/répertoire partagé je ne vois pas mon dossier.

Voici où il se trouve :

Download/SABnzbd/complete/Mavidéo

Le simple fait d'avoir un accent bloque l'explorateur qui m'affiche un message d'erreur "le fichier/dossier n'existe pas"
 

Dami1

Grand Maître Jedi
Darkam a dit:
Cela ne semble pas fonctionner.

Dans contrôle d'accès/répertoire partagé je ne vois pas mon dossier.

Voici où il se trouve :

Download/SABnzbd/complete/Mavidéo

Le simple fait d'avoir un accent bloque l'explorateur qui m'affiche un message d'erreur "le fichier/dossier n'existe pas"

Dans "contrôle d'accès" tu n'as que les dossiers mais pas les sous-dossiers.
Vas dans "explorateur de fichier", puis tu déroules Download, SABnzbd puis complète et enfin Mavidéo => clic droit et "renommer".
si ça ne fonctionne pas vérifie que tu es connecté en admin sous http et tu fais clic droit sur ma Mavidéo et tu changes les droits en faisant clic droit "propriétés".
Enfin n'oublie pas de changer le répertoire de destination dans SABnzbd ;)
 

Darkam

Padawan
Hello,

Je me connecte avec un compte qui a bien les droits d'administrateurs (tient en passant c'est dommage qu'on ne puisse pas supprimer le compte admin, une façon pourtant simple de "sécuriser" un brin les accès que l'on peut faire sur DSM).

Mais sur l'explorateur si je clic sur le dossier pour le renommer, bing, j'ai le message "le fichier/dossier n'existe pas" ...
 

Darkam

Padawan
Bon j'ai demandé au support, le retour à ce jour :
- Il n'est pas possible de créer un répertoire avec un " ' " dedans, enfin du moins pas sous l'explorateur de fichiers
- Par contre il est bien possible de créer un répertoire avec des accents, ce dernier étant accessible comme les autres ensuite

Du coup ils ont renvoyés la demande côté SABnzbd pour enquêter sur l'origine du problème...

Wait & see !
 

Dami1

Grand Maître Jedi
Darkam a dit:
Bon j'ai demandé au support, le retour à ce jour :
- Il n'est pas possible de créer un répertoire avec un " ' " dedans, enfin du moins pas sous l'explorateur de fichiers
- Par contre il est bien possible de créer un répertoire avec des accents, ce dernier étant accessible comme les autres ensuite

Du coup ils ont renvoyés la demande côté SABnzbd pour enquêter sur l'origine du problème...

Wait & see !

je sais. je suis au courant
c'est moi qui leur ai fait remonter le bug des accents qui impacte plus globalement ADM

donc aussi par exemple UPnP Media Server 2. Si vous indexez un répertoire avec accent, vous n'aurez pas accès à l'application sur votre périphérique UPNP / DLNA.

je leur ai remonté chaque voyelle avec chaque accent :geek:
 

Darkam

Padawan
Dami1 a dit:
je sais. je suis au courant
c'est moi qui leur ai fait remonter le bug des accents qui impacte plus globalement ADM

donc aussi par exemple UPnP Media Server 2. Si vous indexez un répertoire avec accent, vous n'aurez pas accès à l'application sur votre périphérique UPNP / DLNA.

je leur ai remonté chaque voyelle avec chaque accent :geek:

Aie, merci ami hamster ! :)

Donc en gros, dans le doute, toujours créer des répertoires n'utilisant que des caractères hexadécimaux...

Je n'ai pas encore testé l'Upnp 2 tient...
 

Dami1

Grand Maître Jedi
hamster
hamster mâle pas hamster dame :lol:

Oui j'ai fait remonter un bug d'accents dans UPnP Media Server 2 qui a été pris comme "critical" (je parle comme van damme - je le respecte mais bon ça fait un peu ça)
Donc oui je conseille à tous en attendant une prochaine update (mise à jour, van damme sors de ce corps) de ne pas créer de dossiers avec accents. pour ceux déjà créées, éditez les
 

Darkam

Padawan
Hello,

Je remonte ce sujet, juste pour préciser que le problème se pause aussi avec les "ç", ça semble logique mais juste pour clarifier ;)
Du coup j'ai un nouveau répertoire "comédie française" qui est bloqué et inutilisable ...

J'espère vraiment qu'Asustor va régler ce problème dans un prochain update, à la longue c'est pénible...
 

Dami1

Grand Maître Jedi
Darkam a dit:
Hello,

Je remonte ce sujet, juste pour préciser que le problème se pause aussi avec les "ç", ça semble logique mais juste pour clarifier ;)
Du coup j'ai un nouveau répertoire "comédie française" qui est bloqué et inutilisable ...

J'espère vraiment qu'Asustor va régler ce problème dans un prochain update, à la longue c'est pénible...

salut
oui le correctif est prévu
bon sang je n'ai pas pensé à la "cédille"
merci Darkam ! je leur remonte ça
pour solutionner, change juste le c cédille par un c normal et réindexe et ça passe
le problème des accents etc. est aussi chez Syno = voir le sujet ouvert par FX ;)
 

camberton

Nouveau membre
Hello,

Juste pour info, j'ai eu exactement le même problème avec Sabnzb (testé la création de dossier qu'avec lui) et j'ai pu renommer/supprimer le dossier en passant par l'explorateur Windows uniquement.

Donc pour l'instant, en effet, vaut mieux éviter les caractères spéciaux.
 

Dami1

Grand Maître Jedi
camberton a dit:
Hello,

Juste pour info, j'ai eu exactement le même problème avec Sabnzb (testé la création de dossier qu'avec lui) et j'ai pu renommer/supprimer le dossier en passant par l'explorateur Windows uniquement.

Donc pour l'instant, en effet, vaut mieux éviter les caractères spéciaux.


Attention tu confonds les applications officielles et tierces. Sabnzb est une application tierce portée par un indépendant (que je connais très bien) sur NAS ASUSTOR. Je travaille avec ASUSTOR depuis plusieurs semaines sur tous les caractères spéciaux de notre belle langue française mais uniquement pour ADM et pour les applications officielles en lien avec ADM. Le dernier en date remonté est l'apostrophe. Les accents et les cédilles ça doit être ou va être corrigé. Je pense leur avoir donné une liste exhaustive. Voilà. Pour info
 

camberton

Nouveau membre
Dami1 a dit:
camberton a dit:
Hello,

Juste pour info, j'ai eu exactement le même problème avec Sabnzb (testé la création de dossier qu'avec lui) et j'ai pu renommer/supprimer le dossier en passant par l'explorateur Windows uniquement.

Donc pour l'instant, en effet, vaut mieux éviter les caractères spéciaux.


Attention tu confonds les applications officielles et tierces. Sabnzb est une application tierce portée par un indépendant (que je connais très bien) sur NAS ASUSTOR. Je travaille avec ASUSTOR depuis plusieurs semaines sur tous les caractères spéciaux de notre belle langue française mais uniquement pour ADM et pour les applications officielles en lien avec ADM. Le dernier en date remonté est l'apostrophe. Les accents et les cédilles ça doit être ou va être corrigé. Je pense leur avoir donné une liste exhaustive. Voilà. Pour info

Hello, en fait je reprenais l'exemple de Darkam (dossier ...\sabnzb\vidéos). J'ai moi aussi fait le test et sabnzb (via les catégories) m'a créé un dossier inutilisable via l'interface Asustor. Pas possible de supprimer ou renommer. Obligé de passer par explorateur Windows.
 

Dami1

Grand Maître Jedi
Donne moi le nom du dossier ici ou par MP. Je vais essayer de reproduire le bug avec une appli
 

camberton

Nouveau membre
Dami1 a dit:
Donne moi le nom du dossier ici ou par MP. Je vais essayer de reproduire le bug avec une appli

Hello, je tente de te répondre, mais j'ai cette erreur (que j'ai souvent) :
 

Pièces jointes

  • err.GIF
    err.GIF
    17.3 KB · Affichages: 866

camberton

Nouveau membre
J'arrive toujours pas à poster mon message. Au cas ou, voici le message que j'ai :

Erreur générale
SQL ERROR [ mysqli ]

Incorrect string value: '\xF0\x9F\x98\x8A' for column 'post_text' at row 1 [1366]

Une erreur SQL est survenue lors du chargement de la page. Si ce problème persiste, veuillez contacter l’administrateur du forum.
 

Dami1

Grand Maître Jedi
As tu essaye d activer MySQL dans adm? As tu contacte le développeur ou le support Asustor ?
 
Haut Bas