Qnap [Moodle/Chamilo] URL d'accès

saeba

Padawan
Bonjour à tous,
J'ai installé via QTS l'application moodle, pour l'instant l'adresse pour y accéder est NomduNAS.myqnapcloud.com/moodle.
J'aimerais utiliser une URL différente de mon choix (je ne veux pas que les personnes qui s'y connectent voient l'adresse ci-dessus).
Est-ce possible ? En utilisant par exemple un nom de domaine préalablement acheté.
Étant donné que je compte également créer un site web, j'aimerais savoir comment faire pour qu'il en soit de même.
Je ne sais pas si j'ai été très clair...
Merci d'avance.
 

FX Cachem

Administreur
Membre du personnel
Oui c'est clair... Je suis sûr que c'est faisable, mais comment ? Désolé, je ne l'ai jamais fait.
 

saeba

Padawan
Bonsoir,
Alors j'ai mis en place le DDNS mais en fait ça ne règle pas mon problème car ça mappe la première partie de l'adresse, celle correspondant au serveur en lui même, du coup je me retrouve avec XXXX.ddns.net/moodle mais les utilisateurs auront toujours accès à la page d'accueil du serveur en enlevant le /moodle.
Mon objectif est que la page de mon serveur ne soit pas accessible aux personnes se connectant à la plateforme moodle.
Quelqu'un aurait-il une solution ?
Merci.
 

QoolBox

Représentant QNAP
si tu as une ip fixe, il suffit de router le champ A du DNS du domaine vers l'ip public fixe.

tu attends 24h que les serveurs DNS se mettent à jours et hop tu accèdes à ton NAS par ton domaine perso

:cool:
 

saeba

Padawan
Merci QoolBox,
Si j'ai bien compris, j'achète un nom de domaine puis j'aurais la possibilité (dans les paramètres du fournisseur de domaine) de rediriger mon ip fixe vers le nom de domaine que j'aurais choisi.
 

giopas

Grand Maître Jedi
Faire cela est simple:

1. tu dois acheter un nom à domain (e.g. domain.com)
2. tu modifies les DNS (CNAME) pour diriger le subdomain (e.g. moodle.domain.com) à "NomduNAS.myqnapcloud.com." (important de garder le point "." à la fin)
3. créer un Virtual Host dans QTS -> Settings -> Web Server -> Virtual Host en suivant les explications ici (cela dépend de comment moodle est configuré, càd s'il utilise une autre porte ou pas): http://forum.qnap.com/viewtopic.php?f=32&t=111660

giopas
 

saeba

Padawan
Merci pour les confirmations et précisions.
Pour la configuration de Moodle j'ai juste suivi les étapes lors de l'installation de l'application Moodle-Beta disponible dans QTS.
 

saeba

Padawan
Bonjour à tous,

J'ai changé d'application (Chamilo plutôt que Moodle) mais mon objectif reste le même que précédemment.
J'ai donc acheté un nom de domaine sur ovh.

Quelle est la meilleure méthode ?

1) Rediriger l'IP:port de l'application mais je ne trouve pas comment ajouter le port (sur ovh je ne peux rediriger que sur l'IP du nas).
2) Rediriger NOMDUNAS.myqnapcloud.com:port mais là encore, je ne trouve pas comment ajouter le port (sur ovh je ne peux rediriger que sur NOMDUNAS.myqnapcloud.com).

Pour le 2), j'ai essayé de suivre les étapes données par giopas en ajoutant une redirection DNS vers une adresse web invisible, où je n'ai pas le choix que de choisir "temporaire (iframe)", mais le champ où je dois rentrer l'adresse n'accepte pas le point à la fin.
Je l'ai rentré sans le point, le nom de domaine me redirige du coup bien vers NOMDUNAS.myqnapcloud.com.

Maintenant il reste à trouver comment configurer pour que cela m'envoie sur Chamilo directement mais je bloque, j'ai essayé d'activé l'hôte virtuel, cela ne fonctionne pas et me bloque carrément l'accès à l'application.

Saeba.
 

QoolBox

Représentant QNAP
non ca marchera pas


faut que ton routeur translate le port 80 vers le port de chamillo
ou alors modifier le HTTP port de Chamillo dans /etc/init.d/chamillo et le basculer en 80 (mails il faut modifer le port d'administration de QTS)

;)
 

saeba

Padawan
C'est bon ça a l'air de marcher, mon nom de domaine me renvoie bien directement sur chamilo, je ne sais pas pourquoi mais cela fonctionne c'est le principal...

Edit : Je me disais bien que ça paraissait bizarre que cela marche...
En fait le fait d'avoir mis le port externe à 80 dans la règle NAT&PAT a fait que l'URL NOMDUNAS.myqnapcloud.com me pointe maintenant directement sur Chamilo et non sur la page d'accueil du NAS, c’est pour ça que la redirection du nom de domaine le fait également...

J'ai vu qu'en rajoutant le port "8080" là je retombais bien sur l’écran d'accueil QTS, personnellement ça ne me dérange pas de le rajouter à la main quand je veux me connecter au NAS depuis l'extérieur mais est-ce une solution acceptable ou à éviter ?

Y a-t-il une autre solution plus "propre" pour que je puisse rediriger seulement l'application et non le NOMDUNAS.myqnapcloud.com en entier, sachant que s'il vient l'idée à un utilisateur de rajouter également le :8080 à la fin du nom de domaine, il retombe sur la page d'accueil du NAS, ce qui ne me plait pas trop...
 

saeba

Padawan
J'ai essayé de suivre les conseils de Giopas en faisant un lien symbolique vers le dossier web du dossier se trouvant dans .qpkg grace au code :

Code:
ln -s /share/CACHEDEV1_DATA/.qpkg/ChamilloLMS/ChamilloLMS/ /share/CACHEDEV1_DATA/Web/ChamilloLMS

Puis j'ai créé mon hôte virtuel.

Mon nom de domaine redirige bien vers Chamilo par contre quand je me connecte, il me rebascule automatiquement dans IPDUNAS:35333/main... En gros je n'ai que la page d'accueil qui est redirigée.

Comment faire pour que toute la navigation dans l'application le soit ?

Merci d'avance.
 

giopas

Grand Maître Jedi
saeba a dit:
Mon nom de domaine redirige bien vers Chamilo par contre quand je me connecte, il me rebascule automatiquement dans IPDUNAS:35333/main... En gros je n'ai que la page d'accueil qui est redirigée.

Comment faire pour que toute la navigation dans l'application le soit ?
Salut saeba, :)

En effet - d'après ma compréhension - avec la méthode du symbolic link tu es en train de rendre accessible un dossier de ton NAS sur la porte 80. Si ce dossier, et l'app qui y est présent, peut tourner sans avoir besoin d'une autre app (comme une session webserver dédié, java ou a web socket connection), alors cela va marcher.

Dans ce cas, il est possible que tu ait accès uniquement à l'index.php (ou fichier similaire), mais que tu n'arrives pas à te connecter à l'application qui tourne derrière.

Si pour toi ce n'est pas embêtant de voir apparaître sur la barre des adresses la porte 35333 une fois connecté (http://IPDUNAS:35333/main), ce que tu peux faire est d'utiliser la méthode de créer dans /share/Web/Chamilo un fichier index.php qui redirige tous les connections vers la bonne porte, ainsi comme décrit ici: http://www.forum-nas.fr/viewtopic.php?f=21&t=2151&hilit=keybox&start=30#p12836 . Le désavantage est qu'en ce cas tu dois laisser aussi la porte 35333 ouverte dans ton firewall alors que dans les autres cas cela n'est pas nécessaire.

Si cette option ne te convient pas, ce que tu pourrais encore faire c'est de créer un reverse proxy, comme décrit ici: http://forum.qnap.com/viewtopic.php?f=32&t=116833&p=521103

saeba a dit:
En fait le fait d'avoir mis le port externe à 80 dans la règle NAT&PAT a fait que l'URL NOMDUNAS.myqnapcloud.com me pointe maintenant directement sur Chamilo et non sur la page d'accueil du NAS, c’est pour ça que la redirection du nom de domaine le fait également...

J'ai vu qu'en rajoutant le port "8080" là je retombais bien sur l’écran d'accueil QTS, personnellement ça ne me dérange pas de le rajouter à la main quand je veux me connecter au NAS depuis l'extérieur mais est-ce une solution acceptable ou à éviter ?

Y a-t-il une autre solution plus "propre" pour que je puisse rediriger seulement l'application et non le NOMDUNAS.myqnapcloud.com en entier, sachant que s'il vient l'idée à un utilisateur de rajouter également le :8080 à la fin du nom de domaine, il retombe sur la page d'accueil du NAS, ce qui ne me plait pas trop...
En gros lignes, si tu n'a rien dans /share/Web toute connection vers la porte 80 est automatiquement redirigée vers le login QTS (normalement porte 8080). Cela est normal.

Donc quand tu vas créer quelque chose dans /share/Web c'est le nouveau contenu qui va prendre le relais.

Pour pouvoir continuer à utiliser NOMDUNAS.myqnapcloud.com uniquement pour le login à QTS, tu peux utiliser l'astuce de forcer la connection SSL sur porte 443 de QTS (par le panneau d'administration du NAS) et d'utiliser un sub.domain que tu detiens pour le virtual host, ainsi chaque fois que tu tapes NOMDUNAS.myqnapcloud.com tu sera redirigé vers https://NOMDUNAS.myqnapcloud.com et accèder ainsi à QTS. Viceversa, si tu tapes http://sub.domain.com tu seras redirigé vers l'application que tu as défini dans le Virtual Host.

En bref, tu dois suivre ce que je t'avais dit il y a quelque post:

giopas a dit:
1. tu dois acheter un nom à domain (e.g. domain.com)
2. tu modifies les DNS (CNAME) pour diriger le subdomain (e.g. moodle.domain.com) à "NomduNAS.myqnapcloud.com." (important de garder le point "." à la fin)
3. créer un Virtual Host dans QTS -> Settings -> Web Server -> Virtual Host

Tiens nous au courant! :)

giopas
 

saeba

Padawan
giopas a dit:
Si pour toi ce n'est pas embêtant de voir apparaître sur la barre des adresses la porte 35333 une fois connecté (http://IPDUNAS:35333/main), ce que tu peux faire est d'utiliser la méthode de créer dans /share/Web/Chamilo un fichier index.php qui redirige tous les connections vers la bonne porte, ainsi comme décrit ici: http://www.forum-nas.fr/viewtopic.php?f=21&t=2151&hilit=keybox&start=30#p12836 . Le désavantage est qu'en ce cas tu dois laisser aussi la porte 35333 ouverte dans ton firewall alors que dans les autres cas cela n'est pas nécessaire.

Le problème c'est que l'application doit être utilisable depuis l’extérieur, si une fois connecté je me retrouve avec http://IPDUNAS:35333/main, ça ne fonctionnera qu'en local.

En fait pour résumer ce que je voudrais c'est que XXX.myqnapcloud.com reste sur QTS et que l'application Chamilo soit accessible via mon nom de domaine mais sans que l'on puisse avoir des informations sur le NAS (son nom, accéder a l’écran QTS à partir de l'url...) après peut importe qu'une fois connecté l'utilisateur est un truc compliqué dans l'URL quand il navigue sur la plateforme Chamilo.

Edit : Comment fait-on pour enlever le lien symbolique ? Suffit-il de supprimer le dossier se trouvant dans le dossier web ?
 

giopas

Grand Maître Jedi
Pour enlever un lien symbolique, il suffit de l'effacer.

Si tu utilises un subdomain et virtual host tu ne donneras jamais le nom ou informations sur ton NAS.

Par example tu peux créer chamilo.saeba.fr sur ton panneau de configuration de ton domain provider avec CNAME [nas].myqnapcloud.com. et cela veut dire que tu devra donner seulement chamilo.saeba.fr à tes utilisateur du service et ils ne sauront même pas que cela tourne sur un NAS.

Régarde les discussions en français (sur ce forum) ou en anglais (sur le forum qnap officiel) que j'ai reporté et tu pourras (peut être comprendre comment j'ai résolu).

De plus compte que si ton router supporte la connection loopback (rebouclage) tu pourras tout simplement utiliser chamilo.saeba.fr même si tu te trouve dans ton LAN.
 

saeba

Padawan
OK, merci pour ces précisions, par contre je viens de m'apercevoir que même si j'enlève tout, lien symbolique, redirection... une fois connecté à Chamilo il me pointe automatiquement sur IPNAS:35333, comment faire pour que cela reste avec [NAS].myqnapcloud.com ou domaine.ovh ?

En fait je ne peux accéder qu'à l'écran de connexion de la plateforme depuis l'extérieur.

Est-ce que cela peut être du au fait qu'ils m'ont demandé après l'installation de mettre le répertoire app/config/ en lecture seule et de supprimer complètement le répertoire main/install/ ?
 
Haut Bas