Synology Je n'arrive pas à connecter plex à mon serveur nas synology DS220+

baddean92

Nouveau membre
Chère communauté,

Tout d'abord bonne année à toute et à tous!

Je fais appel à vous car je m'arrache les cheveux sur la configuration de Plex sur mon serveur NAS (ou l'inverse).

J'ai tout installé mais plex à automatiquement connecté mon PC comme serveur ou il va chercher l'info...
Donc lorsque je lance Plex à partir de mon NAS j'ai le fameux message :
Pas de soupe pour vous !
Vous n'avez pas d'accès à ce serveur.

Ensuite lorsque je clique en haut à gauche sur le logo PLEX puis sur le menu PLUS , j'ai bien mon pc qui est raccorder...
J'ai donc, sur mon plex, les données de mon pc et non celle de mon serveur NAS...
Quand je veux choisir un dossier multimédia il ne me montre que les dossiers de mon pc, mon nas est introuvable.

Je pense que c'est dûe à une mauvaise configuration sur mon nas mais je ne suis pas sur,

Pourriez vous m'aider et me dire comment connecté mon serveur NAS à la place de mon PC?

Merci beaucoup!!
Bonne journée.
 

Pièces jointes

  • 2.PNG
    2.PNG
    56.7 KB · Affichages: 2
  • Erreur 1.PNG
    Erreur 1.PNG
    855.7 KB · Affichages: 2

EVOTk

Modérateur
Membre du personnel
Salut,

Pas de soupe pour vous !
Vous n'avez pas d'accès à ce serveur.
En général ce message ce produit quand un serveur plex a déjà était présent sur la machine et réclamé avec un autre compte plex. Avez vous plusieurs compte plex ?

Sur le nas, arrêter plex
Aller dans le dossier de configuration de plex (il est possible qu'il ne soit pas visible dans file station, aller dans panneau de config , dossier partagé, pour donner les droits de lecture /écriture a votre utilisateurs )
Dans ce dossier , rechercher le fichier Preferences.xml et renommer le en Preferences.xml.old
Redémarrer plex et y accéder depuis :
 
Dernière édition:

baddean92

Nouveau membre
Salut,


En général ce message ce produit quand un serveur plex a déjà était présent sur la machine et réclamé avec un autre compte plex. Avez vous plusieurs compte plex ?

Sur le nas, arrêter plex
Aller dans le dossier de configuration de plex (il est possible qu'il ne soit pas visible dans file station, aller dans panneau de config , dossier partagé, pour donner les droits de lecture /écriture a votre utilisateurs )
Dans ce dossier , rechercher le fichier Preferences.xml et renommer le en Preferences.xml.old
Redémarrer plex et y accéder depuis :
Merci beaucoup pour votre retour.
Non je n'ai qu'un seul compte plex.
Ou se trouve le dossier configuration de Plex?
Votre URL ne fonctionne pas il me renvoie sur un erreur 404.

Merci
 

cadkey

Chevalier Jedi
404 en LAN... Tu ne tapes pas la bonne adresse de ton Nas. L'adresse donnée est bonne ^^
Quelle est l'adresse de ton nas en local?
Le dossier c'est Plex en DSM6.2 et PlexMediaServer en DSM7
 

MilesTEG1

Chevalier Jedi
Après tout dépend de comment le PMS était configuré...
Car moi en http://ip_lan_nas:32400, j'ai ça :
1641846747063.png
Mais de mon coté, c'est parfaitement normal, car j'ai configuré pour que ça ne soit accessible que via https et via le reverse proxy.

Bon je ne pense pas que ce soit le cas ici, mais on n'a pas beaucoup d'infos... Il faudrait l'IP du serveur, etc...

Mais sinon, ça ne serait pas juste le fait qu'il ait installé un autre PMS sur son PC, et qu'il aurait connecté son compte dessus, ce qui aurait désactivé celui sur le NAS ? Je sais pas...
 

cadkey

Chevalier Jedi
L'adresse locale n'est pas http://ip_lan_nas:32400 mais http://ip_lan_nas:32400/web pour atteindre le serveur en local.
Pour réclamer le serveur la première fois c'est obligatoirement en local.
Ce que dit @EVOTk est très juste, c'est la méthode pour récupérer le serveur Plex, mais pas sûr que @baddean92 l'ai fait, pas de retour. Idem pour l'adresse du nas, pas de reponse.
 
Dernière édition:

MilesTEG1

Chevalier Jedi
@cadkey Même chose en mettant le /web :
1641883495171.png

Par contre en https, ça fonctionne moyennant une alerte de sécurité vu qu'avec une IP le certificat ne fonctionne pas :
1641883553253.png

Je disais ça parce que tout dépend de comment tu as configuré ton PMS.

Mon PMS est configuré ainsi :
1641883632391.png
1641883666367.png1641883819776.png

Il faut par contre configurer le reverse proxy pour faire passer les connexions depuis le ndd en HTTPS 443 vers l'IP du NAS sur le port du PMS.
 

cadkey

Chevalier Jedi
Ok. C'est l'adresse locale qui permet de récupérer le serveur. Je crois que je l'avais fait aussi en HTTPS également.
Par rapport à ta config, je ne definis pas 443 en port publique. J'ai gardé 32400 et donc ouvert le port. Mais dans réseau j'ai défini le certificat personnalisé qui correspond à let's encrypt que j'utilise sur mon nas.
J'imagine qu'il a essayé https et http avec la bonne adresse locale.
 
Dernière édition:
Haut Bas